Notes de version



Version 34.0.01.49.60


Générale

  • Exportation au format Autodesk ReCap (.rcp), y compris les images sphériques.
  • Possibilité de créer une surface à partir d'une sélection ou d'une clôture.
  • Images sphériques : Conversion d’unités et de projection.
  • Plusieurs améliorations de l’expérience utilisateur.

Analyses

  • Caténaire/Lignes électriques : Détection et génération d'objets vectoriels améliorées.
  • Caténaires/lignes électriques : Portées et analyses de distance au sol.
  • Caténaire/Lignes électriques : Édition interactive et productivité accrue.
  • Marquage routier : Détection et génération d’objets vectoriels améliorées.

Apprentissage profond

  • Nouvelle implémentation basée sur PyTorch avec performances générales améliorées.
  • Reprise, affinage et création de modèles à partir de modèles pré-entraînés.

Outils

  • Images vers nuage de points : Vue cartographique, sélection d'images et expérience utilisateur bonifiée.

Plusieurs corrections ont également été appliquées à cette version.


Version 34.0.01.28.08


Générale
  • Exportation des éléments du panneau d'objets (surfaces, maillages, cylindres et arbres) au format DWG d'Autodesk.
  • Nouvelle visionneuse CAO avec les options de navigation "Vue réaliste" et "Orbite 3D" lors de l'exportation de fichiers au format DWG.
  • Amélioration de la position de la caméra et de la direction de la vue sur l'interface de la carte VisionLidar.
  • Nouveau module de regroupement de classes permettant une meilleure organisation de celles-ci et de créer des groupes nommés. Dans ces groupes, vous ajoutez les numéros de classe de votre choix, permettant ainsi une utilisation plus adéquate de la gamme complète des 256 classes disponible dans VisionLidar.
  • Nouveau module de regroupement des scans lidar permettant d'organiser les scans par groupes nommés.
  • Amélioration de l'outil Clôture afin de mieux conserver la position de ces derniers lors de changement d'ordinateur.
  • Amélioration du module IFC (BIM) pour avoir accès aux éléments internes de VisionLidar.
  • Compatible avec le nouveau SDK Faro LS 1 1.905.1 (pour FLS, LSPROJ et Workspace) lors de la création de projet.
  • Exportation de la définition de classe de VisionLidar lors de l'enregistrement en format RCP tout en utilisant la nouvelle définition de classe de Autodesk Recap.

Affichage

  • Compatible avec le document de positionnement des images sphériques "Applanix.txt" de la plateforme mobile Applanix.
  • Mise à jour du fichier de positionnement d'images sphériques de Viametris permettant l'utilisation de leur nouvelle sortie d’images équirectangulaires jpeg par multiscan.
  • Amélioration de la vue des images sphériques lors de la combinaison du nuage de points et de la vue des bulles ainsi que des disques d'images.

Analyse

  • Amélioration de la fonction "Analyse par section", qui permet de trouver et de créer des sections par éléments sur une classe et ce le long d'un alignement.
  • Amélioration de l'interface "Analyse du profil".

Plusieurs corrections ont également été appliquées à cette version.




Version 33.0.01.70.11


Générale

  • Nouveau module d’insertion d’objet externe permettant un meilleur contrôle (point d’origine, unités, etc.) sur les éléments 3D insérés (.OBJ ou .PLY).• Nouvel outil de création de mesh coloré à partir de la couleur du nuage de point (sous l’onglet Surface).
  • Exportation de mesh coloré en format “PLY”.
  • Possibilité de transférer un mesh de l’onglet “Surface” vers l’onglet “Objets Insérés” permettant de modifier l’origine de l’objet et de le déplacer dans la scène.
  • Exporter un format RCP en utilisant la notion de Scans pour distribuer le nuage de point sur chaque classe et ainsi avoir le contrôle des classes sur les produits Autodesk.
  • Ajout de plusieurs modèles de caméras à la liste des senseurs compatibles avec le module Image vers scan.

Affichage

  • Récupération des images sphériques provenant de E57 exportés de la plateforme mobile de NAVVIS.
  • Compatible avec le document de positionnement d’images sphériques “pano-poses-registered.csv” provenant de la plateforme mobile de NAVVIS.

Analyse

  • Version améliorée de l’outil “Analyse par section” permettant de créer des sections entre deux points, selon les nœuds d’un alignement, ou par l’analyse des points sur une classe.

Apprentissage profond

  • Utilisation de partition lors de la classification par IA de fichiers LAS à partir de « Nouveau projet » ou « Classifier LAS ».
  • Utilisation de corridors lors de la classification par RN permettant de traiter uniquement les zones convoitées.

Plusieurs corrections ont également été appliquées à cette version.




Version 33.0.01.45.05


Générale

  • Ajout de la possibilité d’utiliser le module de classification par Réseau de neurones à partir de fichiers LAS dès la création du projet (fonction « Nouveau projet »).
  • Nouvelle option de création de maillages colorisés à partir du nuage de points.
  • Option de copier ou de déplacer le maillage vers « Objets insérés » permettant la relocalisation du maillage dans l’interface 3D.
  • Paramétrer la caméra afin d’améliorer la visualisation de l’ombrage sur les surfaces.
  • Inversion rapide de la normale des surfaces.
  • Importation des surfaces de type DXF.
  • Amélioration des entrées de projection et d’unités lors de la création d'un projet.
  • Création d’une ligne de contour délimitant le projet sur la carte et sur VisionLidar365

Affichage

  • Nouvelle fonction d’affichage par normale lorsque le nuage de point n’a ni intensité ni RGB.
  • Version améliorée de l’affichage des zones d’ombrages lors de la visualisation des mailles.

Analyse

  • Option de transfert des points Cogo ou chaines avec Pcode à partir des fonctions : « Détection de Cluster », « Détection de caténaires », « Détection de bordure », « Détection de glissières » et « Ligne de marquage ».
  • Option de transfert vers des points de type Cogo avec Pcode, les objets de type Arbres ou Cylindres

Apprentissage profond

  • Version améliorée de l’interface de visualisation du traitement des partitions traitées et à traiter.
  • Version améliorée de l’information reportée dans le journal.
  • Option de classifier à l’intérieur d’un corridor sélectionné.
  • Nouvelle fonction de classification par apprentissage profond directement sur un lot de fichiers LAS original afin de garder les attribues de tierces parties intactes.

Plusieurs corrections ont également été appliquées à cette version.




Version 32.0.01.102.17


Générale
• Recalage par liste maintenant possible avec le format de nuage de points compatible avec VisionLidar 365.
• Recalage point à point maintenant possible avec le format de nuage de points compatible avec VisionLidar 365.
• Recalage point à point avec fichier externe maintenant possible avec le format de nuage de points compatible avec VisionLidar 365.
• L’option « Déplacer l’Origine » est maintenant possible avec le format de nuage de points compatible avec VisionLidar 365.
• Nouvelle option d’ajouter plusieurs fichiers d’objets volumétriques de type OBJ sur la scène 3D par l’entremise d’un fichier de positions.

Edition
• La fonction “Effaceur” est maintenant disponible avec le format de nuage de points compatible avec VisionLidar 365.
• La fonction “Classifieur” est maintenant disponible avec le format de nuage de points compatible avec VisionLidar 365.

Affichage
• Amélioration de la fonction de coloration du nuage de points par photos sphériques avec l’ajout de nouveaux paramètres.

Analyse
• Amélioration de l’outils Classification aérienne afin de nettoyer certains résidus de la classification par Réseau de Neurone.

Arpentage
• Ajout d’une fonction de mise à jour des élévations nulles (égale à zéro) sur les points Cogo rattachés à votre base de données. La fonction utilisera la moyenne de l’élévation du nuage de points actifs (classe(s) affichée(s)) à l’emplacement du point Cogo (x y) et inséra cette valeur dans le champ z lorsque celle-ci est égale à 0. Aucun point Cogo ayant déjà une valeur d’élévation ne sera impactés.
• Nouvelle fonction de visualisation de Parcelles de terrain en 3D permettant de sélectionner et représenter graphiquement sur votre nuage de points (et la carte de localisation), les parcelles présentes dans votre base de données.

Apprentissage profond
• Nouvelle interface ajoutant une représentation graphique des partitions.
• Représentation chromatique des partitions déjà traitées.
• Ajout d’une section de « Journal » décrivant l’état du traitement.

Mise à jour d’un LAS
• Nouvel outil permettant de mettre à jour certains champs du (des) fichier(s) original(s) de de type LAS ayant permis de créer un projet VisionLidar. Cette fonction permet de sélectionner les attributs à mettre à jour tels les coordonnées 3D, la couleur RGB ou la classe de se connecter au fichier original et de les remplacer par les nouvelles valeurs traitées par les différentes fonctions de Vision Lidar telle que la classification par Apprentissage profond.




Version 32.0.01.77.08


Générale
• Nouveau Format (2022) de fichier pour le nuage de points compatible avec la solution Web VisionLidar 365 de Geo-Plus. VisionLidar demeure compatible avec le format local précédent (.vps). Fini les données en double entre la plate-forme Web et la plateforme Locale.
• Interface simplifiée pour la création de projet permettant le «Glisser-déposer » des fichiers bruts.
• Nouvelle interface pour visualiser le descriptif de projection suivant un code EPSG ou ESRI.
• Les 256 classes du format LAS 1.4 sont désormais prises en charge.
• Nouvelle option pour regrouper les fichiers lors de la fusion des scans de nuage de points pendant la création du projet.
• Exporter en format LAS 1.4 avec 256 classes.

Edition
• Amélioration de l'outil Clôture débutant la saisie du contour dès qu'une nouvelle clôture est créée.
• Nouvelle option pour sélectionner à l'intérieur de la clôture ou exporter les données de la zone de clôture pour l’entraînement d’un modèle DNN.

Analyse
• La détection des bordures fait maintenant partie de VisionLidar Premium et Ultimate.
• La détection des lignes de marquage fait maintenant partie de VisionLidar Premium et Ultimate.
• Nouvelle option pour définir des limites personnalisables sur la fonction Orthophoto Planimétrique.

DNN
• Nouvelle barre de progression lors de la classification par apprentissage profond, offrant un meilleur moyen de suivre la progression de l'ensemble du processus.
• Barre de progression multiple disponible pour les ordinateurs équipés de plus d’une carte graphique permettant de surveiller la progression du processus pour chaque carte individuelle.
• Nouvelle barre de progression implémentée pour le module d’entraînement de modèles par apprentissage profond
• Journal créé pour faire le suivi des traitements.

Paramètres
• Description de la projection en plus du Code.




Version 31.0.01.xx.11


Général
• Correction lors de l’importation de l’intensité pour les fichiers de type PTS et CSV.
• Optimisation de la sélection du code de projection maintenant listé par code EPSG ou code ESRI.
• Exportation des classes visibles vers le format VisionLidar365
• Correction lorsque des points sont supprimés, ces derniers ne sont plus exportés.
• Exportation en format 2.0 de Potree, augmentant ainsi la rapidité d’exportation et concaténation des fichiers en quelques documents binaires.
• Possibilité d’exporter le visualiseur VL365-viewer.exe lors de l’exportation en format VisionLidar365.
• Importante augmentation des performances lors de la création de projets par l’utilisation de l’option Multiprocesseur (Multicore).
• Possibilité de simplifier la densité du nuage de point dès la création du projet.
• Nouveau format d’importation (Workspace « *.fws ») pour fichier provenant des systèmes FARO. Ce format s’ajoute au format déjà existant « *.lsproj » et « *.fls .
• Possibilité d’exporter la vectorisation des poteaux lorsqu’aucune ligne électrique n’est vectorisée.

Outils
• Représentation en 3D des résultats provenant du module Calcul de Volume.
• Module de classification par Réseau de Neurones (Deep Learning).
  a. Compatible avec les nouvelles versions de pilotes NVIDIA CUDA11.x (TensorFlow 2.0).
  b. Possibilité de créer des modèles entraînés par Géométrie (s’ajoutant aux modèles RGB et Intensité).
  c. Possibilité d’ajuster la distance de simplification et le rayon de voisinage lors de la création de modèles entraînés (important pour les modèles aériens).




Version 31.0.01.xx.06


Général
• Importation de documents externes de type surface ou de meshs 3D avec positions absolues (format ply et obj).
• Plus de 2000 nouvelles projections ESRI ont été ajoutées à la liste d’EPSG.
• Le bouton supprimer a été déplacé à l’écart des autres boutons d’édition afin d’éviter les erreurs (sur toutes les fonctions)
• Nouveaux boutons sur la barre d’outils permettant l’activation de la visualisation des images Sphériques : Afficher, Prochain, Précédent
• Amélioration de la rapidité lors de la création de projets.

Édition
• Simplification : les images initiales du projet source sont maintenant recopiées vers le nouveau projet simplifié
• Boite de clipping : Problème corrigé pour l’outil d’application de rotation des axes.

Affichage
• Nouvelle interface cartographique permettant d’afficher la localisation de votre projet ainsi que la position des images sphériques sur un fond de carte fourni par OpenStreetMap (lorsque votre projet est géoréférencé).
• Démarrez l’affichage des images sphériques directement de l’interface cartographique.
• Les images sphériques sont maintenant compressées lorsque la fonction « Redimensionner (n^2) est utilisée.
• Les Images planaires de la plateforme mobile Pegasus de Leica peuvent être maintenant agencées avec le nuage de points.
• Agencement des images sphériques à un numéro de scan maintenant disponible pour les fichiers E57.

Arpentage
• Correction sur l’export en format KML pour la fonction Points/Chaînes

Outils
• Correction sur le module IFC vers OBJ.
• Module de classification par Réseau de Neurone (Deep Learning).
   a. Augmentation des performances.
   b. Transfert du nom des classes provenant du modèle choisi vers le projet courant sur VisionLidar
   c. Affichage du type d’entrainement du modèle choisi : Intensité ou RGB.
   d. Le partitionnement du projet à classifier est maintenant disponible pour les ordinateurs comportant une seule carte graphique de type NVidia augmentant le rendement de la mémoire GPU.
   e. Entrainer un Model : correction sur le transfert du modèle entraîné vers la bonne localisation permettant sa sélection par l’outil « Classifier »
• Amélioration des performances de l’outil Images vers Scans.




Version 30.0.01.xx.40


Mise à jour
• Le caractère «-» est à nouveau accepté dans la dénomination de projet lors de la création de nouveaux projets.
• L’outil translation / rotation du scan applique désormais correctement la rotation sur un point de pivot.
• Module de classification par apprentissage (Réseau de Neurones) est maintenant accessible avec la licence VisionLidar Ultimate.
• Temps de traitement réduit lors de la classification par Réseau de Neurones pour les projets VisionLidar ayant une unité en pied.
• Correction dans le module de classification par Réseau de Neurones en mode CPU.

Outils
• Le module de classification par Réseau de Neurones (Apprentissage profond) peut diviser désormais les grands projets VisionLidar en partitions pour une meilleure gestion de la mémoire GPU.




Version 30.0.01.xx.38

Général
• Mise à jour du format de la base de données rendant plus rapide la réindexation.
• Nouvel outil d’information sur un point cliqué.
• Utilisation du protocole UDP pour envoyer la coordonnée du dernier point cliqué.
• Version améliorée de création de clôture permettant de nommer les vues et les emmagasiner pour utilisation future.
• Nouvel outil normalisé pour la création de clipping box.

Édition
• Nouvelle fonction de sélection avancée permettant la sélection par fenêtre, par polygone, par rayon et par Cluster (points regroupés selon critères).

Affichage
• Recalage des projets incluant des images sphériques.
• Détection automatique de la hauteur de la caméra (images sphériques).
• Ajout de la compatibilité avec les données sphériques de la plateforme mobile Pegasus de Leica.
• Agencement des images sphérique à un numéro de scan.
• Nouvel outil de conversion d’images.
• Ajustement de l’intensité dans la vue en coupe.

Analyse
• Nouvel outil de détection automatique de fils de caténaires et de poteaux électriques à partir de Classes.
• Nouvelle option d’analyse de collision (caténaire/arbre) à multiples distances et formes.
• Nouvel outil de détection de bordure avec nouvel algorithme amélioré. Possibilité de détecter par un seul clic, 2 clics (indiquant l’orientation) et lignes multiples (un clic par ligne).
• Nouvel outil de détection de glissières.
• Nouvel outil de détection de lignes de marquage.
• Option manuelle pour création de cylindre pas 4 clics.

Arpentage
• Visualisation des vecteurs déjà numérisés lors de la création de points et de chaînes en mode arpentage virtuel.
• Bouton obtenant le numéro de ligne suivant.

Classification
• Nouveaux algorithmes de classification de données lidar aérien :
   • Agencement par retour,
   • Analyse de voxel,
   • Analyse par grille.
• Classification du sol, de la végétation et des bâtiments dans un seul jet.

Outils
• Nouvelle interface intégrée pour la création de projets et d’agencement des points de contrôle pour le module « Image vers Scan ».
• Nouveau module de classification par Réseau de Neurones (Deep Learning)
   a. Module permettant la classification avec un modèle entraîné (Sol naturel, sol modifié, végétation haute, basse, poteau, caténaire, auto etc.).
   b. Module de création de modèles entrainés qui permet à l’usager de créer son propre modèle selon ses propres critères.
   c. Module permettant de créer des fichiers d’annotation de nuages de points pour fin d’entraînement.
   d. Segmentation du projet afin de distribuer le traitement sur différents processeurs graphiques (GPU) de l’appareil.
• Nouveau module de classification par couleur (« Couleur vers Classe ») pour images sphériques et images planaires.
   a. Module permettant de sélectionner des points sur un nuage de points en corrélant ces derniers avec une couleur RGB pré annotée sur une image sphérique. Les points sont par la suite transférés sur une classe choisie.
• Nouveau module de conversion de IFC créé par le module BIM vers un format OBJ compatible avec notre plateforme web VisionLidar 365.




Version 30.0.01.xx.20


Général
• Nouveau format du nuage de points intégré dans une base de données SQLite. Augmentation du taux de compression de 3 à 5 fois.
• Interface de création de projet amélioré incluant un bouton de paramétrages avancés.
• Maintenant affichage du nuage de points en mode orthographique en plus de la méthode perspective.
• Nouvelle plateforme de développement compatible avec Linux et macOS
• Temps GPS et nombre de retour maintenant pris en charge dans la structure de donnée.
• Possibilité de sauvegarder un fichier de définition des classes personnalisé et le charger également
• Export en format LAS/LAZ 1.4 (défaut) et 1.2.

Édition
• Nouvel outil de sélection pour nettoyer ou classifier les données par un simple clic définis par un cube ou une sphère (Effaceur, Classificateur).

Affichage
• Amélioration de la vitesse sur l'interface de gestion des images sphériques. Vous pouvez maintenant créer un alignement à partir de la trajectoire des images.
• Nouvel outil d'information sur un points du nuage de points qui permet d'obtenir des métadonnées sur le point sélectionné.
• Nouvel outil Curseur de sélection pour modifier l'interface du curseur, normal, sélectionner sur une surface, disque planimétrique, 2 plans de surface, 3 plans de surface

Analyse
• Nouvel outil de classification utilisant le nombre de retours pour classifier les données lidar aériennes (lorsque le nombre de retours est disponible sur les Las / Laz).
• Amélioration de l'algorithme de détection de trottoir avec possibilité d'utiliser une trajectoire et un alignement. Option de lissage disponible.
• Nouvelle détection des bords pour les bordures verticales et horizontales (un clic ou plusieurs clics).
• Nouvel d'algorithme de détection de lignes de marquage routier permettant l'utilisation de trajectoires.
• Nouvel outil de détection de glissières.
• Nouvelle option pour délimiter un secteur de traitement sur la fonction Orthophotos Planimétriques.
• Insertion manuelle d’arbres (DBH et centroïde détecté par 4 clics).

BIM
• Copiez et dupliquez les items saisis sur un niveau vers un niveau différent (ou sur plusieurs niveaux).
• Importation de groupes (librairies d’ouvertures) depuis des IFC produits par VisionLidar.
• Hauteur des murs adaptée au niveau choisi.
• Bouton Charger pour ouvrir un dessin lorsque plusieurs dessins sont faits sur un projet VisionLidar.

Arpentage
• Saisir points / chaines permet désormais de voir un groupe de chaînes emmagasiné dans la base de données
• Bouton obtenant le numéro de ligne suivant.

Préférences
• Nouvelle structure de paramétrage et amélioration de l’interface.

Outils (nouveau menu)
• La création de projets en lot passe du menu Fichier vers le menu Outils
• Exporter vers VisionLidar 365 en lot passe du menu Fichier vers le menu Outils
• Nouvel outil pour convertir un projet d’un système de coordonnées vers un autre.
• Nouvel outil permettant de convertir d'anciens projets en projet compatible avec la nouvelle structure de donnée VisionLidar 2020.
• Nouvel outil de calcul du volume pour obtenir le volume dans une clôture sur surface simple (un scan) ou une surface multi date (deux scans). Carte chromatique montrant les points chauds
• Nouveau module SFM (Structure From Motion) qui convertit les images aériennes de drones en nuages de points. Module GCP (points de contrôle au sol) pour affiner la position absolue des nuages de points.